2007年3月29日星期四

eclipse 3.0 is too old

今天上午忽然被老板叫去,说我的代码在他的电脑上用不了。我觉得是他jdk版本太老了,他说已经是1.5了,叫我马上过去。
我过去一看,发现他的eclipse是3.0版,可以引用1.5的类库,但是编译器不认1.5的"新"语法,比如for(A a : arrayA)等等。
于是上sheenk.com下了一个3.2版,在看我的代码就行了。

现在jdk6,7都陆续出了,又有了很多新的特性。要是运行java程序不用客户端安装JRE就好了。

没有评论: